IntelliJ IDEA 安装Golang插件

nickso · · 16330 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

网上的例子比较多,这里不重复,只解决我遇到的  --新版本的Intellij无法安装插件的问题。

1、输入仓库网址,搜索不到新的golang插件

2、从https://plugins.jetbrains.com/plugin/5047-go-language-golang-org-support-plugin下载插件,选择 “install plugin from disk”,提示plugin ××× is incompatible with this installation。

3、满足 1、2后恭喜你,无可适配的插件版本。 解压插件zip包,找到lib中 intellij-go-***.jar ,打开jar中的META-INF\plugin.xml,修改 <idea-version since-build="AAA.BBBB" until-build="AAA.*"/> (你的idea版本是 AAA.BBBB.CCC,自己找readme),替换好后,从新打zip包。 

然后,就可以安装了


有疑问加站长微信联系(非本文作者)

本文来自:开源中国博客

感谢作者:nickso

查看原文:IntelliJ IDEA 安装Golang插件

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:701969077

16330 次点击  ∙  1 赞  
加入收藏 微博
5 回复  |  直到 2018-08-20 10:56:27
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传