go get 安装一个特定版本的包失败解决方法

凯文不上班 · · 11127 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

场景描述

go get 下载第三方包golang gin框架时,会去下载gopkg.in/go-playground/validator.v8包以及gopkg.in/yaml.v2包,gopkg.in站点下的包都是中间包,最终的包代码是在github上,于是直接到github.com上去下载,对应的真实代码地址是:
https://github.com/go-playground/validator/tree/v8.18.2
https://github.com/go-yaml/yaml/tree/v2.2.1
于是,我直接go get github.com/go-playground/validator 以及 go get github.com/go-yaml/yaml来获取,能够顺利下载包,但是在编译自己代码时会报错,仔细看了下是由于下载的包版本不对,并没有下载我们想要的版本,go get直接下载的是最新版本

解决方法

直接用git clone的方式去下载特定tag版本的代码,然后拷贝到相应的包目录下边
git clone --branch v8.18.2 https://github.com/go-playground/validator.git
git clone --branch v2.2.1 https://github.com/go-yaml/yaml.git


有疑问加站长微信联系(非本文作者)

本文来自:简书

感谢作者:凯文不上班

查看原文:go get 安装一个特定版本的包失败解决方法

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:701969077

11127 次点击  ∙  1 赞  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传