版本设置X:none node Title golang版本错误

jiangu66 · · 851 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

改章节笔者在广东喝咖啡的时候突然想到的...近期就有想写几篇关于版本设置的博客,所以回家到之后就奋笔疾书的写出来发表了

import C:\go/pkg/windows_386/fmt.a: object is [windows 386 weekly. 
2012-02-22 +96bd78e7d35e X:none] expected [windows 386 weekly. 
2011-12-22 11071 X:none]        main.go

    1:: 编译程序出现上述错误!

    每日一道理
在每个人心中,都曾停留过那些值得怀念的人,也许还在,也许早已消逝,在茫茫人海中丢失,于是,那份怀念便得凄凉,因为模糊的记忆中只剩下一个“空壳”,没有什么,甚至连自己的心都装不下,时间把一切抹平,也把当日的泪水封锁,因为已经没有,怀念只是悲凉!
read Template: template: package.html:79: function "node Title

    2:godoc -http=:9999出现上述错误!

    

    都是因为go.exe版本是1.0.3版本,但是我设置的gopath,gobin等都是版本1.1rc3版的golang.

    解决办法:

    统一版本就能够了。

    

    PS:

    golang语言是不必安装的,也就是说,解压后随便放在一个目录下,

    然后设置好path,gopath,goroot,gobin等参数就能够了。

    

    再PS:

    golang的package是不必自动编译的,把源码放在合适的地方,直接就能够调用了。

    

文章结束给大家分享下程序员的一些笑话语录: 雅虎最擅长的不是开通新业务,是关闭旧业务。

本文来自:博客园

感谢作者:jiangu66

查看原文:版本设置X:none node Title golang版本错误

851 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传