go run 报cannot find package "xxx" in any of: xxx (from $GOROOT)

动物园园长熊熊酱 · · 5538 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

原因

电脑安装的go是1.9.0,而新的项目使用go module,这是golang 1.11.0后才支持的。

解决方法

1.去官网下载最新版本(目前是1.12.0)并且安装。
2.在GoLand的Preferences中,选择Go,再选择Go Module(vgo),然后勾选“Enable Go Modules(vgo) Integration就行了


有疑问加站长微信联系(非本文作者)

本文来自:简书

感谢作者:动物园园长熊熊酱

查看原文:go run 报cannot find package "xxx" in any of: xxx (from $GOROOT)

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:701969077

5538 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传