golang支持linux的最低版本为2.6.23

JGbooks · · 1406 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。
**没错就是官网下载指定的2.6.23** 一 低环境CGO程序出错 ``` 环境: linux系统: centos 5.4 gcc版本 : 4.1.2 glibc 2.5 ``` **注:看了go的历史版本,go 1.9.3 左右对/net/http 修改了,使用大于其以上的版本编译的可执行程序员,运行于低于2.6.23版本系统时,会发生panic.因此使用1.9.0 来测试** go 1.9 版本测试如下: ``` [root@localhost] go build /usr/bin/ld: unrecognized option '--build-id=none' /usr/bin/ld: use the --help option for usage information collect2: ld returned 1 exit status ``` 以上是由于golang 不支持 centos redhat 4.x 或者5.x 系统。因此会出现如上问题    关于此问题的讨论:    https://github.com/golang/go/issues/13052 https://github.com/golang/go/issues/9520 http://blog.nella.org/category/golang/page/2/ **得出结论:** golang 最低支持2.6.23 版本

有疑问加站长微信联系(非本文作者))

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:701969077

1406 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传