golang 依赖包被墙解决方法

IllIIlIlIII · · 4262 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

安装比如gin、iris、gorm等包时,由于众所周知的原因很多依赖包无法安装

go: google.golang.org/api@v0.7.0: unrecognized import path "google.golang.org/api" (https fetch: Get https://google.golang.org/api?go-get=1: dial tcp 216.239.37.1:443: i/o timeout)

一般有如下3种方法解决:

  1. 使用 gopm 进行包管理

  2. 在 github 上找到对应的包地址,再使用 go get 安装

  3. 对于 1.11 以上版本,可以在 go.mod 中通过 replace 替换地址,下方是能满足iris、gin和gorm的依赖

module gin

go 1.12

replace golang.org/x/net => github.com/golang/net latest
replace golang.org/x/tools => github.com/golang/tools latest
replace golang.org/x/crypto => github.com/golang/crypto latest
replace golang.org/x/sys => github.com/golang/sys latest
replace golang.org/x/text => github.com/golang/text latest
replace golang.org/x/sync => github.com/golang/sync latest
replace golang.org/x/exp => github.com/golang/exp latest
replace golang.org/x/lint => github.com/golang/lint latest
replace golang.org/x/oauth2 => github.com/golang/oauth2 latest
replace golang.org/x/time => github.com/golang/time latest
replace golang.org/x/image => github.com/golang/image latest
replace golang.org/x/mobile => github.com/golang/mobile latest
replace cloud.google.com/go => github.com/googleapis/google-cloud-go latest
replace google.golang.org/grpc => github.com/grpc/grpc-go latest
replace google.golang.org/appengine => github.com/golang/appengine latest
replace google.golang.org/genproto => github.com/googleapis/go-genproto latest
replace google.golang.org/api => github.com/googleapis/google-api-go-client latest

有疑问加站长微信联系

本文来自:简书

感谢作者:IllIIlIlIII

查看原文:golang 依赖包被墙解决方法

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:812540095

4262 次点击  
加入收藏 微博
上一篇:第四天
2 回复  |  直到 2019-08-01 10:36:00
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传