不用翻墙解决Go升级1.4后liteIDE找不到godoc的问题

wk3368 · · 6616 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

Go升级到1.4之后,liteIDE启动会提示:

11:29:27 GolangDoc: Could not find godoc, (hint: is godoc installed?)


原因是:

Changes to package source layout

In the main Go source repository, the source code for the packages was kept inthe directory src/pkg, which made sense but differed fromother repositories, including the Go subrepositories.In Go 1.4, the pkg level of the source tree is now gone, so for examplethe fmt package's source, once kept indirectory src/pkg/fmt, now lives one level higher in src/fmt.

Updating: Tools like godoc that discover source codeneed to know about the new location. All tools and services maintained by the Go teamhave been updated. 


解决办法:

1.

翻墙  go get -v -u golang.org/x/tools/cmd/godoc

不翻墙 git clone https://github.com/golang/tools $GOPATH/src/golang.org/x/tools 


2.

go build $GOPATH/src/golang.org/x/tools/cmd/godoc
mv $GOPATH/src/golang.org/x/tools/cmd/godoc/godoc $GOPATH/bin/

本文来自:CSDN博客

感谢作者:wk3368

查看原文:不用翻墙解决Go升级1.4后liteIDE找不到godoc的问题

入群交流(和以上内容无关):Go中文网 QQ 交流群:798786647 或加微信入微信群:274768166 备注:入群;关注公众号:Go语言中文网

6616 次点击  
加入收藏 微博
1 回复  |  直到 2000-01-01 00:00:00
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传