golang go mod 替换指定版本

百里江山 · · 4125 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

之前在项目中遇到过etcd的版本不一致, 导致无法编译. 最终是因为版本不一致的问题.
https://segmentfault.com/q/1010000021762281

go mod替换版本

  1. 先删除vendor: rm -rf vendor 或手动删除
    1.再替版本: go mod edit -require=google.golang.org/grpc@v1.26.0
    1.下载指定版本v1.26.0: go get -u -x google.golang.org/grpc@v1.26.0
    1.然后再go mod vendor

有疑问加站长微信联系(非本文作者)

本文来自:简书

感谢作者:百里江山

查看原文:golang go mod 替换指定版本

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:1006366459

4125 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传