Hyperledger Fabric 2.0 :error getting chaincode bytes: failed to calculate dependencies

逍遥子_ · · 392 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

first network

问题描述

  • 执行‘./byfn.sh up’报错
Error: error getting chaincode bytes: failed to calculate dependencies: incomplete package: github.com/hyperledger/fabric-chaincode-go/shim
!!!!!!!!!!!!!!! Chaincode packaging on peer0.org1 has failed !!!!!!!!!!!!!!!!
========= ERROR !!! FAILED to execute End-2-End Scenario ===========

问题图片

链码安装失败

解决方法

  • 可能是golang的环境变量问题,执行'go env',可以看到GOPROXY的值
go env
GOPROXY
  • 执行以下命令后,再重新运行‘./byfn.sh up’即可成功
go env -w GOPROXY=https://goproxy.cn
export GOPROXY=https://goproxy.cn``

运行成功

运行成功

参考链接

https://www.cnblogs.com/zoujiaojiao/p/12606909.html


有疑问加站长微信联系

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:812540095

392 次点击  
加入收藏 微博
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传