在MAC下安装pip,并关联到相应的python版本

归子莫 · · 88 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

在MAC下安装pip,并关联到相应的python版本

博客说明

文章所涉及的资料来自互联网整理和个人总结,意在于个人学习和经验汇总,如有什么地方侵权,请联系本人删除,谢谢!

说明

不多说了,说就是电脑重装了,全部重新来了

下载pip

首先检查一下是否有pip

pip --version

image-20200422112628804

确定我没有,上面的命令少了一个-,不过肯定的是我没有

下载

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py

安装

sudo python3 get-pip.py

image-20200422113258799

如果是要在python2上安装的话

sudo python get-pip.py

检查

image-20200422113420222

安装成功

切换到国内的源

这个我贴一个地址,我之前写过

https://blog.csdn.net/qq_45163122/article/details/105369865

感谢

万能的网络

以及勤劳的自己


有疑问加站长微信联系(非本文作者)

本文来自:Segmentfault

感谢作者:归子莫

查看原文:在MAC下安装pip,并关联到相应的python版本

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:1006366459

88 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传