idea编译golang插件总结

or2- · · 3578 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

由于使用习惯了Idea 和vim插件。于是下载了idea的go插件并安装,可惜不支持go1.4 ,官方的go插件版本太低 133.326 — 133.9999 。只能手动编译

 

按照这个教程就可以 http://blog.csdn.net/mokt2001/article/details/16962429

 

但是可能有一个问题,如果你安装了1.4的go idea插件又不支持1.4所以,你要先卸载1.4go ,然后安装1.2的go.然后安装idea的插件,然后再编译最新版的go插件

 

还有一个问题。是我编译时候遇到的。就是ant报错 Error:ant: Cannot run 'patch-version' target: JDK

 

解决办法就是不要用idea自带的ant 在 ant build 里

设置自己系统安装的ant

 

然后编译

 

编译环境是 win8.1企业版64bit JDK1.7 64位

这是我编译的 http://pan.baidu.com/s/1gddBqTX  密码 xwu4 


有疑问加站长微信联系(非本文作者)

本文来自:博客园

感谢作者:or2-

查看原文:idea编译golang插件总结

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:701969077

3578 次点击  
加入收藏 微博
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传