Vuls Linux 平台下的漏洞扫描器 Vuls

polaris • 1631 次点击    
这是一个分享于 的项目,其中的信息可能已经有所发展或是发生改变。
Vuls 是一款适用于 Linux / FreeBSD 的漏洞扫描程序,无代理,采用 golang 编写。 对于系统管理员来说,每天必须执行安全漏洞分析和软件更新都是一个负担。为避免生产环境宕机,系统管理员通常选择不使用软件包管理器提供的自动更新选项,而是手动执行更新。这会导致以下问题: 系统管理员必须不断注意NVD(National Vulnerability Database)或类似数据库中的新漏洞。 如果服务器中安装了大量软件,系统管理员可能无法监视所有软件。 执行分析以确定受新漏洞影响的服务器是昂贵的。在分析过程中可能会忽略服务器或两台服务器。 Vuls 是为解决上述问题而创建的工具。它具有以下特点: 通知用户与系统相关的漏洞。 通知受影响的服务器的用户。 自动执行漏洞检测。 使用 CRON 或其他方法定期生成报告。管理漏洞。 ![image](https://static.oschina.net/uploads/space/2017/1029/080947_WAap_2896879.png) ![image](https://static.oschina.net/uploads/space/2017/1029/080612_6Q8g_2896879.png) [![image](https://static.oschina.net/uploads/space/2017/1029/080636_Exx8_2896879.png)](https://asciinema.org/a/bazozlxrw1wtxfu9yojyihick) ![image](https://static.oschina.net/uploads/space/2017/1029/080659_SCga_2896879.png)
授权协议:
GPL
开发语言:
Google Go 查看源码»
操作系统:
Linux
1631 次点击  
加入收藏 微博
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传