hdu 5546/Ancient Go

qq_32944513 · · 938 次点击 · · 开始浏览    
这是一个创建于 的文章,其中的信息可能已经有所发展或是发生改变。

Problem Description
Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.
Here is the rules for ancient go they were playing:
⋅The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
⋅Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.
Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. ′.′ represents an empty cell. ′x′ represents a cell with black chess which owned by Yu Zhou. ′o′ represents a cell with white chess which owned by Su Lu.
Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.
Sample Input
2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o
Sample Output
Case #1: Can kill in one move!!!

Case #2: Can not kill in one move!!!

坑点一:被输入坑死,用gets无限w,至今还不明白为什么。。。。。。

坑点二:注意‘.'什么时候需要标记。既一个连通块不能连续访问一个’.'。


#include <iostream>
#include<stdio.h>
#include<string.h>

using namespace std;
char s[25][25];
int f[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
int sum,v,vis[25][25];
void dfs(int x,int y)
{
    vis[x][y]=1;
    int a,b;
    for(int i=0; i<4; i++)
    {
        a=x+f[i][0],b=f[i][1]+y;
        if(a>=0&&a<9&&b>=0&&b<9&&!vis[a][b]&&s[a][b]!='x')
        {
            if(s[a][b]=='.')
            {
                vis[a][b]=1;
                sum=sum+1;
            }
            else
            {
                dfs(a,b);
            }
        }
    }
}
int main()
{
    int T,B;
    cin>>T;//
    //getchar();
    for(int t=1; t<=T; t++)
    {
        //gets(s[0]);
        cin.get();
        memset(vis,0,sizeof(vis));
        B=0;
        v=1;
        for(int i=0; i<9; i++)
           //scanf("%s",s[i]); //
           //gets(s[i]);
           cin>>s[i];
        for(int i=0; i<9; i++)
        {
            for(int j=0; j<9; j++)
            {
                if(s[i][j]=='o'&&!vis[i][j])
                {
                    memset(vis,0,sizeof(vis));
                    v+=1;
                    sum=0;
                    dfs(i,j);
                    if(sum==1)
                    {
                        B=1;
                        i=10;
                        break;
                    }
                }
            }
        }
        printf("Case #%d: ",t);
        if(B)
            printf("Can kill in one move!!!\n");
        else
            printf("Can not kill in one move!!!\n");
    }
    return 0;
}



有疑问加站长微信联系(非本文作者)

本文来自:CSDN博客

感谢作者:qq_32944513

查看原文:hdu 5546/Ancient Go

入群交流(和以上内容无关):加入Go大咖交流群,或添加微信:liuxiaoyan-s 备注:入群;或加QQ群:692541889

938 次点击  
加入收藏 微博
上一篇:golang
暂无回复
添加一条新回复 (您需要 登录 后才能回复 没有账号 ?)
  • 请尽量让自己的回复能够对别人有帮助
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`
  • 支持 @ 本站用户;支持表情(输入 : 提示),见 Emoji cheat sheet
  • 图片支持拖拽、截图粘贴等方式上传