go get github上的包提示错误!怎么处理,求大神指点指点

deyen · · 513 次点击
你要装的是libxkbcommon的dev包 我用debian的。不知道 fedora 的libxkbcommon dev包是什么 搜了下,估计是这个包 https://fedora.pkgs.org/34/fedora-x86_64/libxkbcommon-devel-1.0.3-2.fc34.x86_64.rpm.html ``` Path /usr/include/xkbcommon/xkbcommon-compat.h /usr/include/xkbcommon/xkbcommon-compose.h /usr/include/xkbcommon/xkbcommon-keysyms.h /usr/include/xkbcommon/xkbcommon-names.h /usr/include/xkbcommon/xkbcommon.h /usr/include/xkbcommon/xkbregistry.h /usr/lib64/libxkbcommon.so /usr/lib64/libxkbregistry.so /usr/lib64/pkgconfig/xkbcommon.pc /usr/lib64/pkgconfig/xkbregistry.pc ```
#3
更多评论
.h是c文件的头 https://github.com/go-vgo/robotgo#requirements ``` For everything else: xcb, xkb, libxkbcommon ``` 安装 libxkbcommon 的dev包
#1
先谢谢,我输入`sudo dnf install xcb xkb libxkbcommon`之后,命令行提示如下,没有xcb和xkb啊。 ``` Repository fedora is listed more than once in the configuration Repository fedora-debuginfo is listed more than once in the configuration Repository fedora-source is listed more than once in the configuration Repository updates is listed more than once in the configuration Repository updates-debuginfo is listed more than once in the configuration Repository updates-source is listed more than once in the configuration 上次元数据过期检查:0:41:44 前,执行于 2022年02月11日 星期五 18时49分35秒。 未找到匹配的参数: xcb 未找到匹配的参数: xkb 软件包 libxkbcommon-1.3.1-1.fc35.x86_64 已安装。 错误:没有任何匹配: xcb xkb ```
#2